BlahBlahCafe Forum Index  
  •  FAQ  •   Search  •   Memberlist  •   Usergroups  •  Register  •   Log in  •   Album  •   Chat  • 

Previous topic :: Next topic
Auto-Login does not work anymore
Author Message
Trance007 


Joined: 27 Mar 2007
Posts: 129
Location: Belgium, Brussels
Posted: Mon Feb 14, 2011 7:15 pm   Auto-Login does not work anymore

Hi,

Every time I come to the forum, I have to enter my login/password again, despite selecting the "Log me on automatically each visit" option at login.
This even if the IP is still the same.
This is really anoying.

Could this be solved ?

Also, could you enable auto-login, even if the IP has changed since last login ?
Actually, I use 3 different computers (home, work, PDA).
Every time I switched from one computer to another, the login/password would need to be entered again.

This is also really annoying.

Thank you for your help. :mrgreen:
 
Nico_Noyau 
Assistant Admin & Bootleg Expert


Age: 30
Joined: 29 Mar 2006
Posts: 13344
Location: Aix en Provence, France
Posted: Mon Feb 14, 2011 9:03 pm   

That's kinda strange, the automatic login works for me here, I use Safari...

I checked the cookies and sessions of the server, it works fine :/
_________________

My music, webdev, photos, videos : www.nicolaskern.fr
Robert Dugenou

Attended :
Teo&Tea showcase in Cannes [France] - 20/05/2007
Théâtre Marigny, Paris [France] - 15/12/2007
<2010> Marseille [France] - 20/03/2010
Monaco - 01/07/2011
Arènes de Nîmes – 14/07/2016
 
Jarreologie6 


Age: 29
Joined: 27 Jul 2010
Posts: 68
Location: Denmark
Posted: Mon Feb 14, 2011 10:20 pm   

Works fine in Firefox.

have you tried to clear your browsers temporary files / cookies, history, etc
it migt fix your problem
_________________
Concerts Attended
In-Doors --> NRGI Arena Aarhus 08.05.2009
2011 Tour --> Jelling Musikfestival 29.05.2011
Electronica World Tour --> Falconer Theatre Copenhagen 26.10.2016
 
Trance007 


Joined: 27 Mar 2007
Posts: 129
Location: Belgium, Brussels
Posted: Mon Feb 14, 2011 10:38 pm   

I experience this problem since the move to zoolook.nl
Same things at home (Firefox), work (Chrome) and on PDA (Opera Mobile 10)

I just cleaned up cache/cookie on my Firefox setup, and still, auto-login doesn't work.

Any help welcome.
 
Trance007 


Joined: 27 Mar 2007
Posts: 129
Location: Belgium, Brussels
Posted: Mon Feb 14, 2011 10:46 pm   

OK, I've just find the problem.

I have a bookmark to http://zoolook.nl/forum/s...rch_id=newposts

On the old host, going to this url would auto-login me, and then show the "Posts since last visit".
In the new host, it does not work anymore.

If I begin with the main page: http://www.zoolook.nl , the auto-login works.

So, could this be fixed ?
 
GeeJee 
The GUV'NOR


Age: 33
Joined: 28 Mar 2006
Posts: 18852
Location: Zwolle, The Netherlands
Posted: Tue Feb 15, 2011 2:09 am   

Why do you use a bookmark to that specific page? All new posts you haven't read are marked bright orange when you log in. Still, if you would like to use that page, is it that much of an effort to just log in like everybody else and go there manually?
_________________
Me, I'm the Guv'nor, not yer regular cheese grater! SO DON'T GIVE ME NO BACK TALK! :mrgreen:
 
Nico_Noyau 
Assistant Admin & Bootleg Expert


Age: 30
Joined: 29 Mar 2006
Posts: 13344
Location: Aix en Provence, France
Posted: Tue Feb 15, 2011 11:52 am   

Trance007 wrote:
OK, I've just find the problem.

I have a bookmark to http://zoolook.nl/forum/s...rch_id=newposts

On the old host, going to this url would auto-login me, and then show the "Posts since last visit".
In the new host, it does not work anymore.

If I begin with the main page: http://www.zoolook.nl , the auto-login works.

So, could this be fixed ?

The cookies sessions are stored when you visit www.zoolook.nl
I can't store cookies when you visit the domain name without subdomain (www), the only way would be to make some sort of a hack to redirect anybody connecting to zoolook.nl to www.zoolook.nl, but this is indeed a bad bad hack... :?
_________________

My music, webdev, photos, videos : www.nicolaskern.fr
Robert Dugenou

Attended :
Teo&Tea showcase in Cannes [France] - 20/05/2007
Théâtre Marigny, Paris [France] - 15/12/2007
<2010> Marseille [France] - 20/03/2010
Monaco - 01/07/2011
Arènes de Nîmes – 14/07/2016
 
Trance007 


Joined: 27 Mar 2007
Posts: 129
Location: Belgium, Brussels
Posted: Tue Feb 15, 2011 12:07 pm   

Indeed !

So, the problem was that my bookmark pointed to http://zoolook.nl instead of http://www.zoolook.nl (my mistake, sorry).

Problem solved, thank you for your help! :fine:

Another question: Is the auto-login enabled even when the IP is different from the last one?
 
Nico_Noyau 
Assistant Admin & Bootleg Expert


Age: 30
Joined: 29 Mar 2006
Posts: 13344
Location: Aix en Provence, France
Posted: Tue Feb 15, 2011 1:49 pm   

The auto-login is based on cookies, which can be found in your web browser's temporary folder.

The cookie is a small text file, composed of the url of the forum (www.zoolook.nl), your username and password.
No information about your IP is stored on the forum to connect you, which means that if you use another browser / computer on the same IP address than the IP you just used to connect, you will be asked to enter it again, as it's stored in the web browser's folder ;)
_________________

My music, webdev, photos, videos : www.nicolaskern.fr
Robert Dugenou

Attended :
Teo&Tea showcase in Cannes [France] - 20/05/2007
Théâtre Marigny, Paris [France] - 15/12/2007
<2010> Marseille [France] - 20/03/2010
Monaco - 01/07/2011
Arènes de Nîmes – 14/07/2016
 
Trance007 


Joined: 27 Mar 2007
Posts: 129
Location: Belgium, Brussels
Posted: Thu Feb 17, 2011 9:19 pm   

Well, you're right.

The auto-login is not linked to the IP.
Tryed with different IP on the same computer, and it works.

But, it seems the auto-login is tied to one PC only.

Here is what I just tryed :
On my home computer
1) I login to BlahBlahCafe, with the "Log me on automatically each visit" set
2) I close the browser
3) I Reopen the browser and go to www.zoolook.nl
4) I am automatically connected
5) Just to be sure, I repeat step 2 to 4
-> Auto login works on my home computer

on my PDA
(using my home Wifi connection, thus having the same public IP as the one on my home computer):
6) I login to BlahBlahCafe, with the "Log me on automatically each visit" set
7) I close the browser
8 ) I Reopen the browser and go to www.zoolook.nl
9) I am automatically connected
-> Auto login works on my PDA

on my home computer
10) I Reopen the browser and go to www.zoolook.nl
-> Auto login does not work

So, auto-login works on a computer, as long as you don't login on another computer.

Is this a bug or a feature ?
 
Nico_Noyau 
Assistant Admin & Bootleg Expert


Age: 30
Joined: 29 Mar 2006
Posts: 13344
Location: Aix en Provence, France
Posted: Fri Feb 18, 2011 1:39 pm   

I have no idea... we use the features of phpBB, so if phpBB does that, we do that :P
_________________

My music, webdev, photos, videos : www.nicolaskern.fr
Robert Dugenou

Attended :
Teo&Tea showcase in Cannes [France] - 20/05/2007
Théâtre Marigny, Paris [France] - 15/12/2007
<2010> Marseille [France] - 20/03/2010
Monaco - 01/07/2011
Arènes de Nîmes – 14/07/2016
 
GeeJee 
The GUV'NOR


Age: 33
Joined: 28 Mar 2006
Posts: 18852
Location: Zwolle, The Netherlands
Posted: Fri Feb 18, 2011 5:23 pm   

Trance007 wrote:
Is this a bug or a feature ?


It's a feature I'm afraid. I have encountered the same problem on some social networks..
_________________
Me, I'm the Guv'nor, not yer regular cheese grater! SO DON'T GIVE ME NO BACK TALK! :mrgreen:
 
Trance007 


Joined: 27 Mar 2007
Posts: 129
Location: Belgium, Brussels
Posted: Sat Feb 19, 2011 12:41 am   

Thank you for your feedback(s).

I think I can live with it. :)
 
Display posts from previous:   
Reply to topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Add this topic to your bookmarks
Printable version

Jump to:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Template FIBlack modified by Falcone
Page generated in 0.14 second. SQL queries: 11